{
targetPkgs = pkgs: with pkgs; [
bash
gnumake
coreutils
stdenv.cc.cc
ncurses5
ncurses
zlib
xorg.libX11
xorg.libXrender
xorg.libxcb
xorg.libXext
xorg.libXtst
xorg.libXi
freetype
gtk2
glib
libxcrypt-legacy
gperftools
glibc.dev
fontconfig
liberation_ttf
lsb-release
# Xilinx ISE
glib
iproute2
libstdcxx5
libusb-compat-0_1
libuuid
motif
# motif3-compat
xorg.libXcursor
xorg.libXft
xorg.libXmu
xorg.libXp
xorg.libXt
xorg.libXrandr
xorg.libSM
xorg.libICE
# to compile some xilinx examples
opencl-clhpp
ocl-icd
opencl-headers
# Vitis
python3
swt
(pkgs.runCommandLocal "swt-4" {} ''
mkdir -p $out/lib
ln -s ${swt}/lib/libswt-pi-gtk-4527.so $out/lib/libswt-pi4-gtk.so
'')
gtk3
jdk21
xorg.xlsclients
# Debug
strace
# "arch" is needed for vitis
toybox
unzip
(lib.hiPrio gcc)
];
}