@@ 29,6 29,8 @@
(build-system pyproject-build-system)
(propagated-inputs (list python-ujson))
(native-inputs (list python-coverage
+ python-setuptools
+ python-wheel
python-setuptools-scm
python-pycodestyle
python-pyflakes
@@ 52,6 54,7 @@
(uri (pypi-uri "docstring-to-markdown" version))
(sha256
(base32 "0gdpabnyl1kyy0cjrnph6xl4fyhgim50a1amsaqq3hahki6i2ip1"))))
+ (native-inputs (list python-setuptools python-wheel))
(build-system pyproject-build-system)
(home-page "")
(synopsis "On the fly conversion of Python docstrings to markdown")
@@ 89,8 92,8 @@
(base32 "0pxx85nms0zs54s1rlrkpkharkkiqcqzxi9q1vjm7qnp0z50g0rz"))))
(build-system pyproject-build-system)
(propagated-inputs (list python-mypy python-lsp-server-1.11.0 python-tomli))
- (native-inputs (list python-coverage python-pytest python-pytest-cov
- python-tox))
+ (native-inputs (list python-setuptools python-wheel python-coverage
+ python-pytest python-pytest-cov python-tox))
(home-page "https://github.com/python-lsp/pylsp-mypy")
(synopsis "Mypy linter for the Python LSP Server")