~ruther/guix-exprs

21f6078dda0e45f672fe1ce79e35d5bfadda5526 — Rutherther 2 months ago d3c0702
chore: update rust packages and their deps
2 files changed, 45 insertions(+), 304 deletions(-)

M ruther/packages/ripgrep-all.scm
M ruther/packages/vhdl-ls.scm
M ruther/packages/ripgrep-all.scm => ruther/packages/ripgrep-all.scm +30 -52
@@ 33,13 33,13 @@
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t
                     #:cargo-inputs (("rust-filetime" ,rust-filetime-0.2)
                                     ("rust-futures-core" ,rust-futures-core-0.3)
                                     ("rust-libc" ,rust-libc-0.2)
                                     ("rust-redox-syscall" ,rust-redox-syscall-0.3)
                                     ("rust-tokio" ,rust-tokio-1)
                                     ("rust-tokio-stream" ,rust-tokio-stream-0.1)
                                     ("rust-xattr" ,rust-xattr-1))))
       #:cargo-inputs (("rust-filetime" ,rust-filetime-0.2)
                       ("rust-futures-core" ,rust-futures-core-0.3)
                       ("rust-libc" ,rust-libc-0.2)
                       ("rust-redox-syscall" ,rust-redox-syscall-0.3)
                       ("rust-tokio" ,rust-tokio-1)
                       ("rust-tokio-stream" ,rust-tokio-stream-0.1)
                       ("rust-xattr" ,rust-xattr-1))))
    (home-page "https://github.com/vorot93/tokio-tar")
    (synopsis
     "Rust implementation of an async TAR file reader and writer. This library does not


@@ 68,9 68,9 @@ memory all at once.")
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t
                     #:cargo-inputs (("rust-crossbeam-channel" ,rust-crossbeam-channel-0.5)
                                     ("rust-rusqlite" ,rust-rusqlite-0.31)
                                     ("rust-tokio" ,rust-tokio-1))))
       #:cargo-inputs (("rust-crossbeam-channel" ,rust-crossbeam-channel-0.5)
                       ("rust-rusqlite" ,rust-rusqlite-0.31)
                       ("rust-tokio" ,rust-tokio-1))))
    (home-page "https://github.com/programatik29/tokio-rusqlite")
    (synopsis "Asynchronous handle for rusqlite library")
    (description


@@ 91,47 91,25 @@ memory all at once.")
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t
                     #:cargo-inputs (("rust-generic-array" ,rust-generic-array-0.12)
                                     ("rust-num" ,rust-num-0.2))))
       #:cargo-inputs (("rust-generic-array" ,rust-generic-array-0.12)
                       ("rust-num" ,rust-num-0.2))))
    (home-page "https://github.com/aticu/size_format")
    (synopsis "Allows for easier formatting of sizes")
    (description
     "This package provides Allows for easier formatting of sizes.")
    (license (list license:expat license:asl2.0))))

(define-public rust-pretty-bytes-0.2
  (package
    (name "rust-pretty-bytes")
    (version "0.2.2")
    (source
     (origin
       (method url-fetch)
       (uri (crate-uri "pretty-bytes" version))
       (file-name (string-append name "-" version ".tar.gz"))
       (sha256
        (base32 "05jkd1f824b93jh0jwfskba9hd70crvjz2nl1hf2xgqx5kfnx780"))))
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t
                     #:cargo-inputs (("rust-atty" ,rust-atty-0.2)
                                     ("rust-getopts" ,rust-getopts-0.2))))
    (home-page "https://github.com/banyan/rust-pretty-bytes")
    (synopsis "Convert bytes to a human readable string")
    (description
     "This package provides Convert bytes to a human readable string.")
    (license license:expat)))

(define-public rust-mime2ext-0.1
  (package
    (name "rust-mime2ext")
    (version "0.1.52")
    (version "0.1.53")
    (source
     (origin
       (method url-fetch)
       (uri (crate-uri "mime2ext" version))
       (file-name (string-append name "-" version ".tar.gz"))
       (sha256
        (base32 "0w2cb2nmfnj7npkn1kvy1pcyknxdh7676mwqn5j0xm7bd585ma51"))))
        (base32 "0fmr2kbcyrxfp9glpplwx0x72p4szr9anhxh93l6bj36jvf66nji"))))
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t))


@@ 164,20 142,20 @@ memory all at once.")
(define-public rust-dyn-clonable-impl-0.9
  (package
    (name "rust-dyn-clonable-impl")
    (version "0.9.0")
    (version "0.9.2")
    (source
     (origin
       (method url-fetch)
       (uri (crate-uri "dyn-clonable-impl" version))
       (file-name (string-append name "-" version ".tar.gz"))
       (sha256
        (base32 "1icrjdqiriiy6abxpsygyxylgxg2gq5j9z876pslqdrwazm413jm"))))
        (base32 "0fi1fy6r2zaq88n21yszlcdbm66iz3xi2dbgl8vrm5sq83ap31ky"))))
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t
                     #:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
                                     ("rust-quote" ,rust-quote-1)
                                     ("rust-syn" ,rust-syn-1))))
       #:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
                       ("rust-quote" ,rust-quote-1)
                       ("rust-syn" ,rust-syn-2))))
    (home-page "https://github.com/kardeiz/objekt-clonable")
    (synopsis "Attribute wrapper for dyn-clone")
    (description "This package provides Attribute wrapper for dyn-clone.")


@@ 186,19 164,19 @@ memory all at once.")
(define-public rust-dyn-clonable-0.9
  (package
    (name "rust-dyn-clonable")
    (version "0.9.0")
    (version "0.9.2")
    (source
     (origin
       (method url-fetch)
       (uri (crate-uri "dyn-clonable" version))
       (file-name (string-append name "-" version ".tar.gz"))
       (sha256
        (base32 "1m4zlp5phn44znxqj6dkjilxpr5kvyil2ldxp77658h7wvq354jf"))))
        (base32 "01885xap4dmln3yspzyr0mmcwnm9mdhlp80ag0iig3nmpywznvm3"))))
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t
                     #:cargo-inputs (("rust-dyn-clonable-impl" ,rust-dyn-clonable-impl-0.9)
                                     ("rust-dyn-clone" ,rust-dyn-clone-1))))
       #:cargo-inputs (("rust-dyn-clonable-impl" ,rust-dyn-clonable-impl-0.9)
                       ("rust-dyn-clone" ,rust-dyn-clone-1))))
    (home-page "https://github.com/kardeiz/objekt-clonable")
    (synopsis "Attribute wrapper for dyn-clone")
    (description "This package provides Attribute wrapper for dyn-clone.")


@@ 218,13 196,13 @@ memory all at once.")
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t
                     #:cargo-inputs (("rust-async-compression" ,rust-async-compression-0.3)
                                     ("rust-chrono" ,rust-chrono-0.4)
                                     ("rust-crc32fast" ,rust-crc32fast-1)
                                     ("rust-log" ,rust-log-0.4)
                                     ("rust-pin-project" ,rust-pin-project-1)
                                     ("rust-thiserror" ,rust-thiserror-1)
                                     ("rust-tokio" ,rust-tokio-1))))
       #:cargo-inputs (("rust-async-compression" ,rust-async-compression-0.3)
                       ("rust-chrono" ,rust-chrono-0.4)
                       ("rust-crc32fast" ,rust-crc32fast-1)
                       ("rust-log" ,rust-log-0.4)
                       ("rust-pin-project" ,rust-pin-project-1)
                       ("rust-thiserror" ,rust-thiserror-1)
                       ("rust-tokio" ,rust-tokio-1))))
    (home-page "https://github.com/Majored/rs-async-zip")
    (synopsis "An asynchronous ZIP archive reading/writing crate")
    (description

M ruther/packages/vhdl-ls.scm => ruther/packages/vhdl-ls.scm +15 -252
@@ 79,19 79,19 @@ skiplist is implemented, as well as an ordered skiplist and a skipmap.")
    (description
     "This package provides Approximate quantiles using histograms with logarithmically sized bins to
guarantee worst case absolute relative error.")
    (license license:expat)))
    (license #f)))

(define-public rust-dactyl-0.7
  (package
    (name "rust-dactyl")
    (version "0.7.2")
    (version "0.7.4")
    (source
     (origin
       (method url-fetch)
       (uri (crate-uri "dactyl" version))
       (file-name (string-append name "-" version ".tar.gz"))
       (sha256
        (base32 "0nrkpcflk37jwkgnch252rlqmbacgm3wpplv9h5krbxx1g0n8d2z"))))
        (base32 "0jdhmcxjr70q690xb19asnpv1vffv5m462glrzk6ncxijjmx3jky"))))
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t))


@@ 124,44 124,17 @@ formatting.")
    (description "This package provides a simple micro-benchmark runner.")
    (license license:wtfpl2)))

(define-public rust-regex-1
  (package
    (name "rust-regex")
    (version "1.10.6")
    (source
     (origin
       (method url-fetch)
       (uri (crate-uri "regex" version))
       (file-name (string-append name "-" version ".tar.gz"))
       (sha256
        (base32 "06cnlxwzyqfbw1za1i7ks89ns4i2kr0lpg5ykx56b8v7dd6df6a2"))))
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t
       #:cargo-inputs (("rust-aho-corasick" ,rust-aho-corasick-1)
                       ("rust-memchr" ,rust-memchr-2)
                       ("rust-regex-automata" ,rust-regex-automata-0.4)
                       ("rust-regex-syntax" ,rust-regex-syntax-0.8))))
    (home-page "https://github.com/rust-lang/regex")
    (synopsis
     "An implementation of regular expressions for Rust. This implementation uses
finite automata and guarantees linear time matching on all inputs.")
    (description
     "This package provides An implementation of regular expressions for Rust.  This implementation uses
finite automata and guarantees linear time matching on all inputs.")
    (license (list license:expat license:asl2.0))))

(define-public rust-vhdl-lang-macros-0.83
  (package
    (name "rust-vhdl-lang-macros")
    (version "0.83.0")
    (version "0.83.1")
    (source
     (origin
       (method url-fetch)
       (uri (crate-uri "vhdl_lang_macros" version))
       (file-name (string-append name "-" version ".tar.gz"))
       (sha256
        (base32 "1qcymmk881ivbi9cpa7v1n4cyj5278gx12w4q4ill8gar006211s"))))
        (base32 "186l183yqhnf42m8bpzmj189zzsrklrzvh4a0z3hzfdhsg221cb5"))))
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t


@@ 172,147 145,6 @@ finite automata and guarantees linear time matching on all inputs.")
    (description "This package provides VHDL Language Frontend - Macros.")
    (license license:mpl2.0)))

(define-public rust-winnow-0.6
  (package
    (name "rust-winnow")
    (version "0.6.18")
    (source
     (origin
       (method url-fetch)
       (uri (crate-uri "winnow" version))
       (file-name (string-append name "-" version ".tar.gz"))
       (sha256
        (base32 "0vrsrnf2nm9jsk1161x1vacmi3ns4h3h10fib91rs28zd6jbvab8"))))
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t
       #:cargo-inputs (("rust-anstream" ,rust-anstream-0.3)
                       ("rust-anstyle" ,rust-anstyle-1)
                       ("rust-is-terminal" ,rust-is-terminal-0.4)
                       ("rust-memchr" ,rust-memchr-2)
                       ("rust-terminal-size" ,rust-terminal-size-0.2))))
    (home-page "https://github.com/winnow-rs/winnow")
    (synopsis "byte-oriented, zero-copy, parser combinators library")
    (description
     "This package provides a byte-oriented, zero-copy, parser combinators library.")
    (license license:expat)))

(define-public rust-toml-edit-0.22
  (package
    (name "rust-toml-edit")
    (version "0.22.20")
    (source
     (origin
       (method url-fetch)
       (uri (crate-uri "toml_edit" version))
       (file-name (string-append name "-" version ".tar.gz"))
       (sha256
        (base32 "07ffw4626k6abicjxb2idh12f1p5fn965zk660zhqsyj5b048g2q"))))
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t
       #:cargo-inputs (("rust-indexmap" ,rust-indexmap-2)
                       ("rust-kstring" ,rust-kstring-2)
                       ("rust-serde" ,rust-serde-1)
                       ("rust-serde-spanned" ,rust-serde-spanned-0.6)
                       ("rust-toml-datetime" ,rust-toml-datetime-0.6)
                       ("rust-winnow" ,rust-winnow-0.6))))
    (home-page "https://github.com/toml-rs/toml")
    (synopsis "Yet another format-preserving TOML parser")
    (description
     "This package provides Yet another format-preserving TOML parser.")
    (license (list license:expat license:asl2.0))))

(define-public rust-toml-datetime-0.6
  (package
    (name "rust-toml-datetime")
    (version "0.6.8")
    (source
     (origin
       (method url-fetch)
       (uri (crate-uri "toml_datetime" version))
       (file-name (string-append name "-" version ".tar.gz"))
       (sha256
        (base32 "0hgv7v9g35d7y9r2afic58jvlwnf73vgd1mz2k8gihlgrf73bmqd"))))
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t
       #:cargo-inputs (("rust-serde" ,rust-serde-1))))
    (home-page "https://github.com/toml-rs/toml")
    (synopsis "TOML-compatible datetime type")
    (description "This package provides a TOML-compatible datetime type.")
    (license (list license:expat license:asl2.0))))

(define-public rust-serde-spanned-0.6
  (package
    (name "rust-serde-spanned")
    (version "0.6.7")
    (source
     (origin
       (method url-fetch)
       (uri (crate-uri "serde_spanned" version))
       (file-name (string-append name "-" version ".tar.gz"))
       (sha256
        (base32 "0v9h2nlg8r7n7dkbgj1aw59g35kl869l652wc6zi2f4zawqinnzb"))))
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t
       #:cargo-inputs (("rust-serde" ,rust-serde-1))))
    (home-page "https://github.com/toml-rs/toml")
    (synopsis "Serde-compatible spanned Value")
    (description "This package provides Serde-compatible spanned Value.")
    (license (list license:expat license:asl2.0))))

(define-public rust-toml-0.8
  (package
    (name "rust-toml")
    (version "0.8.19")
    (source
     (origin
       (method url-fetch)
       (uri (crate-uri "toml" version))
       (file-name (string-append name "-" version ".tar.gz"))
       (sha256
        (base32 "0knjd3mkxyb87qcs2dark3qkpadidap3frqfj5nqvhpxwfc1zvd1"))))
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t
       #:cargo-inputs (("rust-indexmap" ,rust-indexmap-2)
                       ("rust-serde" ,rust-serde-1)
                       ("rust-serde-spanned" ,rust-serde-spanned-0.6)
                       ("rust-toml-datetime" ,rust-toml-datetime-0.6)
                       ("rust-toml-edit" ,rust-toml-edit-0.22))))
    (home-page "https://github.com/toml-rs/toml")
    (synopsis
     "native Rust encoder and decoder of TOML-formatted files and streams. Provides
implementations of the standard Serialize/Deserialize traits for TOML data to
facilitate deserializing and serializing Rust structures.")
    (description
     "This package provides a native Rust encoder and decoder of TOML-formatted files
and streams.  Provides implementations of the standard Serialize/Deserialize
traits for TOML data to facilitate deserializing and serializing Rust
structures.")
    (license (list license:expat license:asl2.0))))

(define-public rust-unsafe-libyaml-0.2
  (package
    (name "rust-unsafe-libyaml")
    (version "0.2.11")
    (source
     (origin
       (method url-fetch)
       (uri (crate-uri "unsafe-libyaml" version))
       (file-name (string-append name "-" version ".tar.gz"))
       (sha256
        (base32 "0qdq69ffl3v5pzx9kzxbghzn0fzn266i1xn70y88maybz9csqfk7"))))
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t))
    (home-page "https://github.com/dtolnay/unsafe-libyaml")
    (synopsis "libyaml transpiled to rust by c2rust")
    (description "This package provides libyaml transpiled to rust by c2rust.")
    (license license:expat)))

(define-public rust-serde-yaml-0.9
  (package
    (name "rust-serde-yaml")


@@ 337,45 169,22 @@ structures.")
    (description "This package provides YAML data format for Serde.")
    (license (list license:expat license:asl2.0))))

(define-public rust-serde-json-1
  (package
    (name "rust-serde-json")
    (version "1.0.122")
    (source
     (origin
       (method url-fetch)
       (uri (crate-uri "serde_json" version))
       (file-name (string-append name "-" version ".tar.gz"))
       (sha256
        (base32 "1nk8phyvwmhrmcbwdr8rbjd9bqp8np62dcbnhisgymqwjl1n4jvq"))))
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t
       #:cargo-inputs (("rust-indexmap" ,rust-indexmap-2)
                       ("rust-itoa" ,rust-itoa-1)
                       ("rust-memchr" ,rust-memchr-2)
                       ("rust-ryu" ,rust-ryu-1)
                       ("rust-serde" ,rust-serde-1))))
    (home-page "https://github.com/serde-rs/json")
    (synopsis "JSON serialization file format")
    (description "This package provides a JSON serialization file format.")
    (license (list license:expat license:asl2.0))))

(define-public rust-subst-0.3
  (package
    (name "rust-subst")
    (version "0.3.3")
    (version "0.3.7")
    (source
     (origin
       (method url-fetch)
       (uri (crate-uri "subst" version))
       (file-name (string-append name "-" version ".tar.gz"))
       (sha256
        (base32 "182bsg8pn7ch7j0kyz1ysp1a2danip4csdpyqfhb70n5zzkkyv96"))))
        (base32 "038n81ns4b8ncjynhif7wq474023chg5mwccxw0xn6gaflk99rrk"))))
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t
       #:cargo-inputs (("rust-memchr" ,rust-memchr-2)
       #:cargo-inputs (("rust-indexmap" ,rust-indexmap-2)
                       ("rust-memchr" ,rust-memchr-2)
                       ("rust-serde" ,rust-serde-1)
                       ("rust-serde-json" ,rust-serde-json-1)
                       ("rust-serde-yaml" ,rust-serde-yaml-0.9)


@@ 386,53 195,6 @@ structures.")
    (description "This package provides shell-like variable substitution.")
    (license (list license:bsd-2 license:asl2.0))))

(define-public rust-strum-macros-0.26
  (package
    (name "rust-strum-macros")
    (version "0.26.4")
    (source
     (origin
       (method url-fetch)
       (uri (crate-uri "strum_macros" version))
       (file-name (string-append name "-" version ".tar.gz"))
       (sha256
        (base32 "1gl1wmq24b8md527cpyd5bw9rkbqldd7k1h38kf5ajd2ln2ywssc"))))
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t
       #:cargo-inputs (("rust-heck" ,rust-heck-0.5)
                       ("rust-proc-macro2" ,rust-proc-macro2-1)
                       ("rust-quote" ,rust-quote-1)
                       ("rust-rustversion" ,rust-rustversion-1)
                       ("rust-syn" ,rust-syn-2))))
    (home-page "https://github.com/Peternator7/strum")
    (synopsis "Helpful macros for working with enums and strings")
    (description
     "This package provides Helpful macros for working with enums and strings.")
    (license license:expat)))

(define-public rust-strum-0.26
  (package
    (name "rust-strum")
    (version "0.26.3")
    (source
     (origin
       (method url-fetch)
       (uri (crate-uri "strum" version))
       (file-name (string-append name "-" version ".tar.gz"))
       (sha256
        (base32 "01lgl6jvrf4j28v5kmx9bp480ygf1nhvac8b4p7rcj9hxw50zv4g"))))
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t
       #:cargo-inputs (("rust-phf" ,rust-phf-0.10)
                       ("rust-strum-macros" ,rust-strum-macros-0.26))))
    (home-page "https://github.com/Peternator7/strum")
    (synopsis "Helpful macros for working with enums and strings")
    (description
     "This package provides Helpful macros for working with enums and strings.")
    (license license:expat)))

(define-public rust-pinned-vec-0.1
  (package
    (name "rust-pinned-vec")


@@ 503,14 265,14 @@ array.")
(define-public rust-vhdl-lang-0.83
  (package
    (name "rust-vhdl-lang")
    (version "0.83.0")
    (version "0.83.1")
    (source
     (origin
       (method url-fetch)
       (uri (crate-uri "vhdl_lang" version))
       (file-name (string-append name "-" version ".tar.gz"))
       (sha256
        (base32 "1i04xilhbdlkk999ffw563qbcnq9sbsjz27v4gyjgnq4y8r9lh36"))))
        (base32 "0l4n9pbja1vwpvcmz3b4darlm90vvyhjkpp09qx6zh1bqp8w3za6"))))
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t


@@ 527,17 289,18 @@ array.")
                       ("rust-rayon" ,rust-rayon-1)
                       ("rust-strum" ,rust-strum-0.26)
                       ("rust-subst" ,rust-subst-0.3)
                       ("rust-toml" ,rust-toml-0.2)
                       ("rust-toml" ,rust-toml-0.4)
                       ("rust-vhdl-lang-macros" ,rust-vhdl-lang-macros-0.83))))
    (home-page "https://github.com/kraigher/rust_hdl")
    (synopsis "VHDL Language Frontend")
    (description "This package provides VHDL Language Frontend.")
    (license license:mpl2.0)))


(define-public vhdl-ls
  (package
    (name "vhdl-ls")
    (version "0.83.0")
    (version "0.83.1")
    (source
     (origin
       (method git-fetch)


@@ 549,7 312,7 @@ array.")
                 (substitute* "vhdl_ls/Cargo.toml"
                   ((", path = \"../vhdl_lang\"") ""))))
       (sha256
        (base32 "09ckkzrxg8lm1laxijm751yh70zziyljplb9mvhl7ag9gh83rfaq"))))
        (base32 "0fs8qghnxw82by8dmlxlvm2spzqq3rk8aywj1ay7jxzwblkpkvq0"))))
    (build-system cargo-build-system)
    (arguments
     `(#:phases

Do not follow this link